Introduction

Dovetail Mobile Agent allows agents to perform support activities anytime, anywhere from web enabled mobile devices.

We ship Dovetail Mobile Agent with source code and facilities to help you automate the build and deployment of customized Dovetail Mobile Agent versions.

In This Chapter

Overview

Getting Help

Next

Overview
Introduction

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 1:32:07 PM
© by Dovetail Software, Inc.


Overview

Dovetail Mobile Agent delivers the most common subset of Dovetail CRM functionality to a mobile platform, so that support agents can still work effectively when away from their desktop.

Search

Dovetail Mobile Agent provides search capabilities using our Dovetail Seeker search product. Agents can use Dovetail Mobile Agent to effectively search the Dovetail CRM system.

Case Management

Using Dovetail Mobile Agent, support agents can go from case creation to case close. Here is a summary of the features available to Dovetail Mobile Agent users.

Create Cases:

  • Find a contact for which you will create a case.
  • Select the contact's site and fill in case details before you create the case.

Viewing a case you can work the case entirely within Dovetail Mobile Agent:

  • Browse dynamically created Case History
  • Send Email regarding a case
  • Call a Contact directly from your mobile device and easily log the conversation to the case
  • Log Notes about work you've done on the case
  • Log Phone Call notes
  • Edit Case details, including title, case type, severity, and priority
  • Close a case
  • Reopen a case
  • Link and Unlink cases to solutions

Subcase Management

Dovetail Mobile Agent user can also work with subcases from creation to close. Here is a summary of subcase features:

  • Create Subcase
  • Send Email regarding a subcase
  • Call a Contact directly from your mobile device and easily log the conversation to the subcase
  • Log Notes about work you've done on the subcase
  • Log Phone Call notes
  • Edit Subcase details, including title, severity, and priority
  • Close a subcase
  • Reopen a subcase

Case and Subcase Workflow

The following Dovetail CRM and workflow operations are supported by both case and subcases:

  • Accept a case from a work queue
  • Assign cases to other agents
  • Change Status
  • Close
  • Dispatch a case to a queue
  • Yank a case from another agent

Knowledge Management

Using Dovetail Mobile Agent, both support agents and users that are not logged can search for and view published solutions.

Public users can:

  • Search for and view public solutions.

Support Agents can:

  • Search for and view all solutions.
  • Easily navigate the relationship between cases and the solutions they are linked to.
  • Send a solution to a case's contact and optionally link the solution to the case.

See Also

Introduction

Getting Help

Next

Getting Help
Overview

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 2:41:55 PM


Getting Help

If you need additional help beyond this user guide, you can use any of the following resources:

  • Dovetail SelfService - Use our online customer support site to notify us of a support issue, to manage your Dovetail products, to seek sales support, or to search the knowledge base.
  • Knowledge Base Articles - Search our online knowledge base for existing issue resolutions.
  • Product Documentation - Find Dovetail's most up-to-date product documentation.
  • Blog Posts - Dovetail developers often publish useful posts about Dovetail Carrier
  • Contact Us - Contact us directly if you need further assistance.
    • support@dovetailsoftware.com
    • phone 800-684-2055 or 512-610-5400

See Also

Introduction

Overview

Next

What's New
Getting Help

Did this topic help you? Email us your feedback.
Last updated: 10/28/2015 3:33:49 PM


What's New

In This Chapter

Version 2.7.2

Version 2.7.1

Version 2.7

Version 2.5

Version 2.1

Version 2.0.3

Version 2.0.2

Version 2.0.1

Version 2.0

Version 1.2.1

Version 1.2

Version 1.1

Next

Installation Guide

Version 2.7.2

Enhancements

Case and Subcase history that contains Markdown gets rendered.

Upgraded to use the latest Dovetail Bootstrap.

Fixes

Case histories that contained long non-breaking strings were throwing the IOS layout off. The iphone.css file was updated to force those long strings to wrap at the right screen edge.

Version 2.7.1

Fixed: Release 2.7 was missing some assemblies so that if you did not have Microsoft MVC Version 4 already installed it would not work.

Version 2.7

Requirements

Dovetail Mobile Agent requires the Microsoft .Net 4.0 framework full edition.

Enhancements

Added a user profile page, which includes email signatures.

A user's email signature is now pre-filled into the Log Email form.

From the site page, show (Contract Manager) contracts for this site, and link to a new contract page.

On the contract page, show covered sites, parts, and contacts.

Added Age In Queue to the queue listings.

Login and logout actions are logged to the fc_login_monitor table.

The Administration page shows the product version, and the number of logged in users.

Styling improvements throughout the application - for both Mobile and Desktop view modes.

Improved the database performance when retrieving open case and subcase listings.

Fixes

Cases with a condition of "Closed - Admin Pending" are now correctly identified as Closed cases.

Comparing the current user's login name to a login name was previously being done in a case-sensitive manner, which could cause assorted issues, such as not recognizing that the current user was the owner of a case if a user logged in with a mixed case user name. Comparisons are now done in a case-insensitive manner.

Fixed a bug that could prevent subcases from being assigned.

Infrastructure

Updated the Dovetail SDK dependency to the latest version.

Updated the ASP.NET MVC framework to use MVC 4.

Upgrading to Version 2.7

  1. Apply the schema changes that are documented in the schema file, found in the \schema directory.
    • This version requires the following schema changes:
      • New Column: table_user.x_signature
      • New View Column: table_fc_user_case_view.condition_queue_time
      • New View Column: table_fc_user_case_view.wipbin_objid
      • New View Column: table_fc_user_case_view.owner_user_objid
      • New Join: table_fc_user_case_view : outer join from case to wipbin
      • New View Column: table_fc_user_subcase_view.condition_queue_time
      • New View Column: table_fc_user_subcase_view.wipbin_objid
      • New View Column: table_fc_user_subcase_view.owner_user_objid
      • New Join: table_fc_user_subcase_view : outer join from subcase to wipbin
  2. Uninstall the existing version of Dovetail Mobile Agent:
    • Go to Control Panel - Add and Remove Programs (for XP), or Programs and Features (for Vista/Windows 7).
    • Uninstall / Remove Dovetail Mobile Agent
  3. Install the new version of Dovetail Mobile Agent
    • Unzip the Dovetail Mobile Agent ZIP file
    • Double-click Dovetail-Mobile-Agent.exe to start the installation

Version 2.5

Requirements

Dovetail Mobile Agent now requires the Microsoft .Net 4.0 framework full edition.

Enhancements

Authentication has been enhanced to have the remember me option keep the user authenticated across browser sessions until they sign out or their cookie expires.

Views with case and subcase history is now generating better HTML and CSS hooks. The most noticeable user facing change is that email headers in history now have detailed styling.

Added attachment support to the SendEmail page for both case and subcases.

Added administration page which allows for refreshing cached data without restarting the application.

Log email will prefill the CC list based on the cases CCList1 and CCList2 fields.

Case attachments are now listed in descending order by date.

Duplicate form submissions are now prevented. For example double clicking create case quickly will now only create one case.

Searching using a date property now allows for easily finding items where the timestamp is within the last X days, or today.

Fixes

Fixed bug when using IE where attachments added would have underscored full paths.

Fixed an issue with Mobile application privilege checking during login.

Infrastructure

Updated the Dovetail SDK dependency. This update contains many bug fixes but notably for Dovetail Mobile Agent it allows for case insensitive login names on Oracle.

Dovetail Mobile Agent has taken a dependency on Dovetail Bootstrap to provide common functionality.

Version 2.1

Enhancements

  • File Attachment handling (uploading and downloading of file attachments)
  • Unified Mobile and Agent Lite master pages
  • Added style selection links to change from mobile to desktop styles
  • Added My Recent Items to home page to show recently accessed cases, subcases, and solutions
  • When sending a case to a solution, the first case in the selection is now selected
  • Allow solutions to be linked to closed cases
  • Changed employee lookup for Assign to filter by both first and last name
  • Improved menus in desktop mode

Upgrading to Version 2.1

  1. Apply the schema changes that are documented in the schema file, found in the \schema directory.
    • This version requires the following schema changes:
      • New Table: recent_obj
  2. Uninstall the existing version of Dovetail Mobile Agent:
    • Go to Control Panel - Add and Remove Programs (for XP), or Programs and Features (for Vista/Windows 7).
    • Uninstall / Remove Dovetail Mobile Agent
  3. Install the new version of Dovetail Mobile Agent
    • Unzip the Dovetail Mobile Agent ZIP file
    • Double-click Dovetail-Mobile-Agent.exe to start the installation

Version 2.0.3

Fixed a bug in search results when configured to have excluded search domains. The attachment domain would not get excluded.

Version 2.0.2

iPhone Mobile Safari Version

New user interface targeted specifically for iPhone Mobile Safari browser.

The new design improves Dovetail Mobile Agent user experience with a native iPhone look and feel.

Version 2.0.1

Search domain filters are now dynamic and will be populated based on the search domains present in your search index. If there is a search domain in your index which you do not wish to expose to Mobile users you can edit an application configuration setting to exclude undesired search domains.

When mobile initializes the Dovetail SDK it will now relay any application configuration settings starting with fchoice which are found in the web.config.

Version 2.0

New Functionality

  • Subcase Functionality (creating, editing, closing, workflow, logging of phone calls, emails and notes, searching, privileges, etc.)
  • Data Restriction, allowing different groups of users to only see certain data within the system
  • Password Reset, allowing a user to reset their own password, should it be lost or forgotten
  • Application-level privilege, allowing administrators to control which users can use Dovetail Mobile Agent.
  • Searching of files and attachments (case attachments, solution attachments, etc.)

Infrastructure

Dovetail Seeker version 2.0 or higher is now required.

The Rulemanager service must be running for the Password Reset feature to function properly.

Version 1.2.1

Bug Fix

Attachments that have spaces in the file path are now correctly wrapped by the anchor tag. Previously a 404 error would be returned since the href was pointing to an incomplete path to the file.

Version 1.2

New Functionality

Agents can now create new cases and edit details about existing cases and log notes to cases.

Note: Case creation uses search for selecting the case contact. This means that Dovetail Seeker needs to be enabled and configured for Create Case functionality to work. See the Requirements for more details.

Contacts are now searchable from the normal search interface. Additionally a contact view has been added displaying contact details and open cases.

Better Customization

Application look and feel is easier to update. It is now possible to swap in a different Master page. An example customized Master page is included called AgentLite which is designed to work well on desktop browsers.

Customization hooks have been added to make it easy to add customized versions of controllers and views that override the baseline implementations. This is helpful when customizing Dovetail Mobile Agent to easily keep customized portions of the application separated for easier management of upgrades.

Bug Fix

Search results that Mobile doesn't know what to do with no longer cause an error. The search results are rendered with a link to a page informing the user that there is no view for this type of search result. It is possible to customize Dovetail Mobile Agent so that it can handle your custom search domains. Please see this knowledge base article for more information.

Infrastructure

Dovetail Mobile Agent now uses the ASP.Net MVC 1.0 release. Because of this the .Net 3.5 SP1 is now required.

Added support for detecting client browser capabilities. Using this knowledge we no longer emit access key cues for browsers that cannot use them (e.g. iPhone) or where it is not appropriate such as with desktop browsers.

Updated mobile to use the latest version of Dovetail SDK which brings support for Amdocs 6 and 7 product families.

Important: Dovetail Mobile Agent users upgrading from version 1.1 will need to apply the schema changes found in the schema directory.

Version 1.1

Added support for Knowledge Management.

  • Solution search and viewing of public solutions is available to unauthenticated web site visitors.
  • Agents can search for and view all solutions.
  • Agents viewing solutions can easily see a listing of the cases linked to the solution.
  • Agents can send a solution to a case's contact and optionally link the solution to the case.
  • Case summaries now show the solution the case is linked to.
  • The case summary now shows the complete case history.The case history page has been removed.
  • Important: Dovetail Mobile Agent users upgrading from version 1.0 will need to apply the schema changes in the schema directory.
What's New

Did this topic help you? Email us your feedback.
Last updated: 11/10/2008 8:55:51 AM


Installation Guide

The following section describes Dovetail Mobile Agent technical requirements, installation steps, and configuration information.

In This Chapter

Requirements

Installation

Database Indexes

Next

Requirements
Installation Guide

Did this topic help you? Email us your feedback.
Last updated: 10/8/2008 6:55:31 PM


Requirements

Dovetail Mobile Agent has the following requirements:

  • .Net Framework Version 4.0 full edition.
  • IIS Version 6 or 7 with ASP.NET enabled.
    • IIS version 6 is present on - Windows Server 2003, 64bit Windows XP.
    • IIS version 7 is present on - Windows Vista, Windows 7, and Windows Server 2008.
  • The following Dovetail Licenses:
    • A Dovetail Mobile Agent License.
    • One Dovetail SDK, one Dovetail Interfaces Toolkit and one Dovetail Support Toolkit license per desired concurrent user of Dovetail Mobile Agent.
  • Dovetail Seeker version 2.0.9 or greater. Contacts must be configured as a valid search domain. Refer to the Dovetail Seeker documentation for information on configuring search domains.
  • Rulemanager is required for the Password Reset functionality.
  • Dovetail Admin is required for configuring privileges and Data Restrictions.

Developers wishing to customize Dovetail Mobile Agent have the following requirements:

  • Visual Studio 2010 or 2012 is the required integrated development environment for application customization.

See Also

Installation Guide

Installation

Database Indexes

Next

Installation
Requirements

Did this topic help you? Email us your feedback.
Last updated: 8/2/2013 3:37:17 PM


Installation

See Also

Installation Guide

Requirements

Database Indexes

Next

Install the Dovetail SDK
Installation

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 9:43:51 AM


Install the Dovetail SDK

Dovetail Mobile Agent uses Dovetail SDK to interact with your Clarify database. Dovetail Mobile Agent customers that have never used another Dovetail SDK based product such as Dovetail Agent with their Clarify database before should install Dovetail SDK to assist with license installation and to verify that Dovetail SDK based applications will work correctly against your Clarify database.

  1. Install the Dovetail SDK. The Dovetail SDK includes the Dovetail Foundation Library and of of the Dovetail API toolkits. Please see the Dovetail SDK documentation for more details.
  2. Use the License Installer to install your license key(s).
  3. Run the Data Verifier to check that there are no inconsistencies or bad data that might prevent Dovetail SDK from initializing properly. The Data Verifier and License Installer are shipped with the Dovetail SDK.

See Also

Installation

Install Dovetail Mobile Agent

Update the Clarify Schema

Configure Dovetail Seeker

Application Configuration

Configure Privileges

Import DAT file for Password Reset template

Optional - Configure Data Restriction

Next

Install Dovetail Mobile Agent
Install the Dovetail SDK

Did this topic help you? Email us your feedback.
Last updated: 10/16/2008 1:57:22 PM


Install Dovetail Mobile Agent

The Dovetail Mobile Agent installer will add a web application named mobile.

  1. Uncompress the Dovetail Mobile Agent zip file.
  2. Run the Dovetail-Mobile-Agent.exe file.
  3. The setup program displays the welcome page of the Dovetail Mobile Agent setup wizard.
  4. Click Next.
  5. The End-User License Agreement page appears.
  6. If you accept the terms in the License Agreement, click Next.
  7. The installation location page appears.
  8. Click Next to accept the default installation path, or enter a custom installation path.
  9. Enter the database credentials to the Dovetail CRM or select Skip database settings, click Next
  10. Select the Web Site where the web application will be installed, click Next
  11. Enter in the URL for the Dovetail Seeker web application, click Next
  12. To complete the installation, click Install.
  13. Update the Clarify Schema
  14. Configure Dovetail Seeker
  15. Review the Application Configuration settings
  16. Review the Application User Permissions
  17. Configure Privileges
  18. Import DAT file for Password Reset template
  19. [OPTIONAL] Configure Data Restriction
  20. Using a web browser, navigate to the Dovetail Mobile Agent URL, i.e. http://localhost/mobile

See Also

Installation

Install the Dovetail SDK

Update the Clarify Schema

Configure Dovetail Seeker

Application Configuration

Configure Privileges

Import DAT file for Password Reset template

Optional - Configure Data Restriction

Next

Update the Clarify Schema
Install Dovetail Mobile Agent

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 4:51:11 PM


Update the Clarify Schema

Dovetail Mobile Agent requires additions to your Clarify Schema. You can change the Clarify schema with either Dovetail's SchemaEditor or Clarify's DDEditor.

Prior to making schema changes, backup the current database.

To make these changes using Dovetail SchemaEditor:

  1. Edit the .SchemaEditor file
    • Set the database connection information.
    • Set the inputFilePath to mobileagent.schemascript.xml
  2. Preview the changes (SchemaEditor.exe -p).
  3. Apply the changes (SchemaEditor.exe -a).

To make these changes using Clarify DDEditor:

  1. Start the DDEditor program.
  2. To save a copy of the database schema to disk, select Save.
  3. Edit the saved schema file.
  4. Edit the mobileagent.sch file. Follow the directions in that file to cut/paste the schema changes into the saved schema file. Use the Apply Changes menu item to compile the new saved schema file.
  5. Exit DDEditor.

See Also

Installation

Install the Dovetail SDK

Install Dovetail Mobile Agent

Configure Dovetail Seeker

Application Configuration

Configure Privileges

Import DAT file for Password Reset template

Optional - Configure Data Restriction

Next

Configure Dovetail Seeker
Update the Clarify Schema

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 2:42:53 PM


Configure Dovetail Seeker

The search and create case capabilities of Dovetail Mobile Agent depend on the search product Dovetail Seeker. The create case feature requires that the Dovetail Seeker configuration is updated to add a document specification for contact search. This is included with Dovetail Seeker 2.0

  • Make sure Dovetail Seeker is enabled.
  • Make sure Contacts are configured as a valid search domain within Dovetail Seeker. This is accomplished by having a Dovetail document specification present within the documentSpecifications.xml file with the displayName of Contact. An example is provider in the documentSpecifications.xml file that ships with with Dovetail Seeker.
  • Follow the Dovetail Seeker instructions for re-indexing your search index.

See Also

Installation

Install the Dovetail SDK

Install Dovetail Mobile Agent

Update the Clarify Schema

Application Configuration

Configure Privileges

Import DAT file for Password Reset template

Optional - Configure Data Restriction

Next

Application Configuration
Configure Dovetail Seeker

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 2:19:01 PM


Application Configuration

If you skipped the database settings section during the install, you must edit the configuration file which tells Dovetail Mobile Agent how to talk to the Dovetail database.

Application Settings

From the directory where you installed Dovetail Mobile Agent, in the webapplication subdirectory, edit the the web.config file using your favorite text editor.

Key

Required

Default

Comments

DovetailDatabase.Type

Yes

mssql

Your database type. Either mssql or oracle

DovetailDatabase.ConnectionString

Yes

Data Source=server; Initial Catalog=dovetail; User Id=user; Password=password;

Database connection string.
Note: Review the the Application User Permissions needed by the user Id in the connection string.

Seeker.IsSearchEnabled

Yes

True

Whether search is enabled or not.

Seeker.SeekerServiceUrl

Yes

http://localhost/seeker

The URL for Dovetail Seeker

Seeker.ExcludedSearchDomains

No

(empty)

Comma delimited list of search domains which you do not wish Mobile users to be able to search by.

DovetailDatabase.SessionTimeoutInMinutes

Yes

20

Number of minutes until an inactive session is terminated.

ItemHistory.AttachmentPathPrefixExpression

Yes

c:\\dovetail\\attachments

A regular expression used to match the path prefix for attachments, as used in doc_path entries.

Subcase.DueDateNumberOfDaysAfterCreation

Yes

7.0

When a subcase is created, the due date will be set to the creation date plus this value (in days).

Subcase.PriorWarningInHours

Yes

8.0

When a subcase is created, the warning notification for the upcoming due date will be set to the due date minus this value (in hours).

Attachment.AttachmentMode

Yes

ModeB

Specifies which sub-folder mode Dovetail Mobile Agent should use when saving attachments.

NOTE: The value is NOT case-sensitive (i.e. 'modea' works as well as 'MODEA').

Valid values are:

ModeA: Put all files directly into the path specified by attachPath.

ModeB: Put attachments in subfolders using the CASE ID as a folder prefix.

For example, if the attachPath is set to "c:\attachments", attachments from Case 1792 will be stored in the path:

C:\attachments\001xxx\001792\

This mode groups up to a 1,000 cases in a grouping folder to help organize the attachments.

ModeC: Similar to ModeB but the folder names are slightly different.

For example, if the attachPath is set to "c:\attachments", attachments from Case 1792 will be stored in the path:

C:\attachments\1700\1792\

This mode groups up to 100 cases in a group folder to help organize the attachments.

Attachment.FilePath

Yes

c:\\attach

A regular expression used to match the path prefix for attachments, as used in doc_path entries.

Dovetail SDK Settings

Any application settings present in the web.config which start with fchoice will be used when initializing the Dovetail SDK. For more information on available fchoice SDK configuration settings please see the Dovetail SDK documentation.

Sample Application Settings

Below is a sample of the application settings from the web.config shipped with Dovetail Mobile Agent:

<appSettings>

    <add key="DovetailDatabase.Type" value="mssql"/>

    <add key="DovetailDatabase.ConnectionString" value="Data Source=localhost; Initial Catalog=dovetail; User Id=sa; Password=sa"/>

    <add key="Seeker.IsSearchEnabled" value="true"/>

    <add key="Seeker.SeekerServiceUrl" value="http://mysearchserver/seeker"/>

    <!-- Comma delimited list of domain names which should not be used by mobile.-->

    <add key="Seeker.ExcludedSearchDomains" value="" /

    <add key="DovetailDatabase.SessionTimeoutInMinutes" value="20"/>

    <!-- When subcases are created the due date will be set by adding this value of days to the creation time -->

    <add key="Subcase.DueDateNumberOfDaysAfterCreation" value="7.0"/>

    <!-- When subcases are created the prior warning will be this many hours. -->

    <add key="Subcase.PriorWarningInHours" value="8.0"/>

    <add key="Attachment.AttachmentMode" value="ModeB" />

    <add key="Attachment.FilePath" value="c:\\attach" />

</appSettings>

See Also
Installation
Install the Dovetail SDK
Install Dovetail Mobile Agent
Update the Clarify Schema
Configure Dovetail Seeker
Configure Privileges
Import DAT file for Password Reset template
Optional - Configure Data Restriction

Next
Application User Permissions

 Application Configuration

            Did this topic help you? Email us your feedback.

Last updated: 1/12/2012 5:20:49 PM


Application User Permissions

The Mobile application user (as configured in the connection string in the Application Configuration) needs to have permission to change password for other users.

This is how the Password Reset functionality is accomplished.

Microsoft SQL Server

One way to accomplish this is to add the application user to the securityadmin database role.

EXEC master..sp_addsrvrolemember @loginame = N'username', @rolename = N'securityadmin'

(where username is the application user name)

Oracle

One way to accomplish this is to grant the ALTER USER privilege to the application user

grant alter user to username;

(where username is the application user name)

Additional Information

For additional information, refer to the following Dovetail Knowledgebase article: https://support.dovetailsoftware.com/selfservice/solutions/show/413

See Also

Application Configuration

Attachments

Next

Attachments
Application User Permissions

Did this topic help you? Email us your feedback.
Last updated: 5/18/2016 2:33:41 PM


Attachments

Storing Attachments

When an attachment is added to a case or subcase, a copy of the file is saved to the attachment server. The configuration for Attachment.FilePath determines the path to the storage location, and the Attachment.AttachmentMode determines the folder structure for the file storage location. If saving attachments to a network share, proper permissions are required to access the network and read/write access to the attachments directory.

For example, if the Attachment.AttachmentMode is set to ModeB and the Attachment.FilePath is set to "c:\attachments", attachments from Case 1792 will be stored in the path:

C:\attachments\001xxx\001792\

UNC paths also work for the Attachment.FilePath. If it is set to "\\attachmentServer\attachments\", then attachments from Case 201 will be stored in the path:

\\attachmentServer\attachments\000xxx\000201\

Refer to the Application Configuration section for more details on these configuration settings.

Downloading/Viewing Attachments

Dovetail Mobile Agent uses Dovetail Seeker (and Dovetail SeekerProxy) to serve up the attachment files from the attachment storage location to the user's web browser.

See Also

Application Configuration

Application User Permissions

Next

Configure Privileges
Attachments

Did this topic help you? Email us your feedback.
Last updated: 1/12/2012 5:25:10 PM


Configure Privileges

Privileges in Dovetail Mobile Agent are administered the same way as privileges in Dovetail Admin and Dovetail Agent.

Application Privilege

There is a Mobile application privilege. This allows administrators to allow or deny access to the entire Dovetail Mobile Agent application based on Privilege Class.

Note: If this privilege does not exist in your database, then all users will have access to Dovetail Mobile Agent.

  1. Import the Privclass DAT file into your database.
  2. Grant access to the Mobile privileges using Dovetail Admin.

Operation Privileges

Operation privileges enable or disable individual operations, such as Create Case, Close Case, Dispatch, Create Subcase, etc.

Dovetail Mobile Agent uses the same privileges for operations as Dovetail Agent.

Grant access to the individual operation privileges using Dovetail Admin.

See Also

Installation

Install the Dovetail SDK

Install Dovetail Mobile Agent

Update the Clarify Schema

Configure Dovetail Seeker

Application Configuration

Import DAT file for Password Reset template

Optional - Configure Data Restriction

Next

Import the Privclass DAT file
Configure Privileges

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 10:16:48 AM


Import the Privclass DAT file

The privclass_import.dat file is located in the files subdirectory under the Dovetail Mobile Agent Installation directory.

To import a data file using Dovetail ArchiveManager (DIET)

Execute the following command:

<path>\diet.exe
-user_name <user>
-password <pass>
-db_server <serv>
-db_name <db>
-import <file>
where:
<path> is the path to the diet program
<user> is the system administrator user
<pass> is the system administrator password
<serv> is the database server name
<db> is the database name
<file> is the name of the file to import. If the <file> is not in the current directory, specify the path to the directory it is in.

To import a data file using dataex

Execute the following command:

<path>\dataex
-user_name <user>
-password <pass>
-db_server <serv>
-db_name <db>
-imp <file>
where:
<path> is the path to the dataex program
<user> is the system administrator user
<pass> is the system administrator password
<serv> is the database server name
<db> is the database name
<file> is the name of the file to import. If the <file> is not in the current directory, specify the path to the directory it is in.

Note: Each file should import with 0 errors and 0 warnings. If there are any errors or warnings, examine the dataex.mes file for possible problems.

See Also

Configure Privileges

Grant access to the Mobile privileges

Next

Grant access to the Mobile privileges
Import the Privclass DAT file

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 2:43:41 PM


Grant access to the Mobile privileges

Web privclasses allow you to decide which operations a specific user (or group of users) may perform. Using Dovetail Admin, you can turn on (or off) virtually any operation in the application.

By default, no operations are initially enabled for any privclasses. You must use Dovetail Admin to grant privileges to users.

To modify the web privclasses

  1. Start Dovetail Admin in your browser and log in.
  2. From the navigation menu on the left, select Privilege Classes.
  3. Find and select the Privilege Class you want to modify.
  4. In the lower frame, check the commands to be enabled for this privclass.
  5. On the Apps tab, enable the Mobile privilege if available. This will only be available if the Privclass DAT file was imported.
  6. On the General and Support tabs, enable the operation privileges according to your specific business needs.

Select Save.

Repeat for additional privilege classes as necessary

See Also

Configure Privileges

Import the Privclass DAT file

Next

Import DAT file for Password Reset template
Grant access to the Mobile privileges

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 2:46:29 PM


Import DAT file for Password Reset template

The password_reset.dat file contains a template used when sending an email to a user who has requested that their password be reset. This must be imported into your database.

Import the password_reset.dat file into your database. This file is located in the files subdirectory under where Dovetail Mobile Agent was installed. (Refer to Import the Privclass DAT file for instructions on how to import a DAT file.)

See Also

Installation

Install the Dovetail SDK

Install Dovetail Mobile Agent

Update the Clarify Schema

Configure Dovetail Seeker

Application Configuration

Configure Privileges

Optional - Configure Data Restriction

Next

Optional - Configure Data Restriction
Import DAT file for Password Reset template

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 4:13:22 PM


Optional - Configure Data Restriction

In Dovetail Mobile Agent, data restriction allows your database to be partitioned into logical, virtual databases.

For example, you can use data restriction to partition your database by geographical regions. In this scheme, users can only see the sites, contacts, cases, and solutions for their own region. When they search or query for contacts or cases, it will appear that they are querying the entire database, but in fact, they will only see sites within their restriction area.

If you plan to use Data Restrictions

Note: Data Restriction is a powerful feature, but does require careful consideration and planning. It is highly recommended that you consult with Dovetail Software before implementing Data Restriction.

Configuring Data Restriction

  1. Follow the instructions on setting up Data Restriction per the installation instructions in Dovetail Agent and Dovetail Admin.
  2. Import the res_clause_data.dat file into your database. (Refer to Import the Privclass DAT file for instructions on how to import a DAT file.)
  3. Configure the Document Specifications within Dovetail Seeker to include Data Restriction custom fields on any domain that should be restricted.
    If needed, re-index those domain specifications to include restriction data.
    Important Note: Dovetail Seeker 2.0.9 or higher is required for Data Restricted searches.

See Also

Installation

Install the Dovetail SDK

Install Dovetail Mobile Agent

Update the Clarify Schema

Configure Dovetail Seeker

Application Configuration

Configure Privileges

Import DAT file for Password Reset template

Next

Database Indexes
Optional - Configure Data Restriction

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 5:34:40 PM


Database Indexes

It is recommended to work with your DBA to properly index your database so as to optimize performance.

The following indexes can improve the application's performance:

Table | Column(s) | Database | Unique?
fc_login_monitor | fcsessionid | All | Yes
fc_login_monitor | s_fcsessionid | Oracle | Yes

See Also

Installation Guide

Requirements

Installation

Next

Customization
Database Indexes

Did this topic help you? Email us your feedback.
Last updated: 8/22/2013 11:00:44 AM


Customization

The Dovetail Mobile Agent deployment includes source code, tests, and build automation for developers wishing to customize the web application.

Tooling Requirements

Developers will need Visual Studio 2010 and a good comfort level with C# and an understanding of Model View Controller (MVC) architecture.

Important: Before opening the Dovetail Mobile Agent solution located in the source directory you will need to run the ASP.NET MVC Installer.

Source Code

The source code and Visual Studio solution for Dovetail Mobile Agent can be found in the source subdirectory where you installed Dovetail Mobile Agent.

Customization

We have a created two customization extension points to assist you in keeping your customizations separated from baseline Dovetail Mobile Agent code. These conventions are in place to help make it easier to see the differences between baseline Dovetail Mobile Agent code and your customizations. They should also make it a bit easier to upgrade your customizations if future versions of Dovetail Mobile Agent should modify the code your customizations are based on. In addition it is possible to customize the application Master page to brand Dovetail Mobile Agent to better suit your organization and to include alternate stylesheets and javascript files.

Customizing Views

The simplest customization would be View customization. If you do not like how a view is rendered you can customize the view creating an alternate copy of the view in a CustomViews directory which mirrors the baseline Views directory. When a custom version of a view is present it will always be used in lieu of the original.

Views for a given controller action can be customized by copying the baseline view into the 'CustomViews\<controller name>' directory. This is easy to do in visual studio doing a Control+Drag of the view you wish to copy into the corresponding custom view directory. For example if you want to customize the look and feel of the CaseSummary view on the Cases controller views you would do the following:

  • Open the \source\Dovetail.Mobile.Agent directory
  • Create a new Cases folder under the CustomViews folder. /CustomViews/Cases/
  • Copy the original baseline view into your new folder. Ctrl+Drag the CaseSummary.aspx file to /CustomViews/Cases
  • Edit the namespace of the custom view's aspx.cs file to jibe with its new namespace. Dovetail.Agent.Mobile.Custom Views.Cases.CaseSummary
  • Edit the inherits attribute of the .aspx page header to include the .Custom namespace.

<%@ Page CodeBehind="CaseSummary.aspx.cs" Inherits="Dovetail.Agent.Mobile.CustomViews.Cases.CaseSummary"%>

Customizing Controllers

When you want to add additional information to the Model consumed by an action's view model you will need to customize both the controller and the view. To create a copy of the existing baseline controller suitable for customization you should to do the following:

  • Copy the controller class file you wish to customize into the CustomControllers directory.
  • To avoid confusion you could rename the controller file and class name to Custom<X>Controller where <X> is the name of the controller being customized. For example CasesController would become CustomCasesController.
  • It would be a good idea to change the namespace of the customized controller to be Dovetail.Agent.Mobile.Controllers.CustomControllers.
The controller factory will first look for a controller named Custom before looking for the traditional controller. For example every request to a route having /cases/ will first look for a CustomCasesController and then the CasesController.

Tests

Dovetail Mobile Agent includes the same tests that Dovetail uses to verify the release. We encourage developers that wish to customize Dovetail Mobile Agent to use good testing practices.

Build Automation

Dovetail Mobile Agent uses a tool called NAnt to automate common tasks like compiling code, running tests, and deploying tested code. Helpful batch files are included at the root of the deployment to make it easy to running tests or build a release.

  • run-mobile-agent-tests.bat - run NUnit tests that are found in the Dovetail Mobile Agent test project.
    • Please edit the test-properties target in the build automation file mobileagent.build to have the desired credentials for your test database.
  • build-mobile-agent-for-release.bat - prepares a release of your customized Dovetail Mobile Agent
  • create-mobile-web-application-for-iis7.bat - builds a release of your customized Dovetail Mobile Agent and creates a web application for it on the local machine's web server.
    • Requires IIS 7
    • You may wish to edit this batch file to control the web application naming.

Next
Using Dovetail Mobile Agent

 Customization

            Did this topic help you? Email us your feedback.

Last updated: 1/9/2012 2:57:00 PM


Using Dovetail Mobile Agent

The following section describes how to use Dovetail Mobile Agent.

In This Chapter

Search

Working with Cases

Working with Subcases

Working with Attachments

Creating a case

Viewing cases or subcases in your queues

Monitoring workgroup activities

Working with solutions

Password Reset

Next

Search
Using Dovetail Mobile Agent

Did this topic help you? Email us your feedback.
Last updated: 10/8/2008 6:55:42 PM


Search

Dovetail Mobile Agent uses Dovetail Seeker to enable users and agents to search for cases, subcases, contacts, and solutions. The types of items returned by search depends on the user. An authenticated user can search for everything, while unauthenticated users can only search for public solutions. Users can also search for cases, subcases, and solutions by ID number.

  1. From the Home screen, select Search.
  2. Enter your search criteria and select Go.

    The search results list all items matching your search criteria.

    When your search matches a case, subcase, or solution identifier (e.g. "3"), the listing will show a short summary of that item at the top of the search results.

  3. Select the result to view the full details of that object.

See Also

Using Dovetail Mobile Agent

Working with Cases

Working with Subcases

Working with Attachments

Creating a case

Viewing cases or subcases in your queues

Monitoring workgroup activities

Working with solutions

Password Reset

Next

Working with Cases
Search

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 2:49:16 PM


Working with Cases

Some of the actions you can take on a case vary, depending on the case's owner. However, you can take the following actions on all open cases, regardless of its owner:

  • Send Email: Send an email directly from Dovetail Mobile Agent. The email is logged as note to the case.
  • Call Contact: Call the contact directly from Dovetail Mobile Agent. After you're through with the call, you can log a phone note to the case.
  • Log Note: Log a note to the case history. Attachments can also be added while logging a note.
  • Add Attachment: Log a note and add an attachment to the case.

To work on a case you own

  1. Open the case. You can open a case you own in two ways:
    • Select My Items from the Home screen or elsewhere, and select a case from the list.
    • Select Search from the Home screen or elsewhere, search for the case, and select it from the list.
  2. From the Case Summary page of a case you own, you can perform the following actions:
    • Assign: Assign a case you own to someone else.
    • Dispatch: Dispatch a case you own to a work queue.
    • Change Status: Change the case's status and enter notes about the change.
    • Close Case: Close the case.
    • Edit Case: Change the title, case type, severity, or priority of the case.
    • Find Solution: Search for a solution to the case. From the Solution page, you can email the solution to the customer, and link the solution to the case.
    • Unlink Solution: If a case has a linked solution, you can Unlink it, thus breaking the relationship between the case and solution.
    • Create Subcase: You can create a new subcase, which can be routed and worked independently of the case itself.

Note: Only the most common actions will be available on the main Case Summary page. Less common actions will be available by clicking the More... link.

To work on a case someone else owns

  1. Open the case. You can open a case someone else owns in two ways:
    • Select Your Workgroup's Recent Activity from the Home screen or elsewhere and select a case from the list.
    • Select Search from the Home screen or elsewhere, search for the case, and select it from the list.
  2. From the Case Summary page of a case you don't own, you can perform the following action:
    • Yank: Take a case that has not been dispatched, or take a dispatched case from a work queue you do not belong to.

To work on a case dispatched to a queue

  1. Open the case. You can:
    • Select a queue from the Home screen and select a case from the list.
    • Select Search from the Home screen or elsewhere, search for the case, and select it from the list.
  2. From the Case Summary page of a case in a queue, you can perform the following action:
    • Accept: Accept a case if it has been dispatched to a queue that you are a member of.

To work on a closed case

  1. You cannot do any work on a case that has been closed. If you wish to work on the case, you can:
    • Reopen Case: This will put the case into an Open condition, where it can then be worked.

See Also

Using Dovetail Mobile Agent

Search

Working with Subcases

Working with Attachments

Creating a case

Viewing cases or subcases in your queues

Monitoring workgroup activities

Working with solutions

Password Reset

Next

Working with Subcases
Working with Cases

Did this topic help you? Email us your feedback.
Last updated: 1/9/2012 4:30:39 PM


Working with Subcases

Some of the actions you can take on a subcase vary, depending on the subcase's owner. However, you can take the following actions on all open subcases, regardless of its owner:

  • Send Email: Send an email directly from Dovetail Mobile Agent. The email is logged as note to the subcase.
  • Call Contact: Call the contact directly from Dovetail Mobile Agent. After you're through with the call, you can log a phone note to the subcase.
  • Log Note: Log a note to the subcase history. Attachments can also be added while logging a note.
  • Add Attachment: Log a note and add an attachment to the subcase.

To work on a subcase you own

  1. Open the subcase. You can open a subcase you own in two ways:
    • Select My Items from the Home screen or elsewhere, and select a subcase from the list.
    • Select Search from the Home screen or elsewhere, search for the subcase, and select it from the list.
  2. From the Subcase Summary page of a subcase you own, you can perform the following actions:
    • Assign: Assign a subcase you own to someone else.
    • Dispatch: Dispatch a subcase you own to a work queue.
    • Change Status: Change the subcase's status and enter notes about the change.
    • Close Subcase: Close the subcase.
    • Edit Subcase: Change the title, severity, or priority of the subcase.

Note: Only the most common actions will be available on the main Subcase Summary page. Less common actions will be available by clicking the More... link.

To work on a subcase someone else owns

  1. Open the subcase. You can open a subcase someone else owns in two ways:
    • Select Your Workgroup's Recent Activity from the Home screen or elsewhere and select a subcase from the list.
    • Select Search from the Home screen or elsewhere, search for the subcase, and select it from the list.
  2. From the Subcase Summary page of a subcase you don't own, you can perform the following action:
    • Yank: Take a subcase that has not been dispatched, or take a dispatched subcase from a queue you do not belong to.

To work on a subcase dispatched to a queue

  1. Open the subcase. You can:
    • Select a queue from the Home screen and select a subcase from the list.
    • Select Search from the Home screen or elsewhere, search for the subcase, and select it from the list.
  2. From the Subcase Summary page of a subcase in a queue, you can perform the following action:
    • Accept: Accept a subcase if it has been dispatched to a queue that you are a member of.

To work on a closed subcase

  1. You cannot do any work on a subcase that has been closed. If you wish to work on the subcase, you can:
    • Reopen Subcase: This will put the subcase into an Open condition, where it can then be worked.

See Also

Using Dovetail Mobile Agent

Search

Working with Cases

Working with Attachments

Creating a case

Viewing cases or subcases in your queues

Monitoring workgroup activities

Working with solutions

Password Reset

Next

Creating a case

Working with Attachments

Adding an Attachment

  1. Open the case or subcase, and click Log Note (or Add Attachment).
  2. Fill in the note text.
  3. Click Choose File, and find the file to attach.
  4. Click Log Note.

Viewing an Attachment

  1. Open the case or subcase.
  2. Click on the file name listed in the Attachments section to open the file, or follow the link to each attachment in the History section.

Working with Subcases

Did this topic help you? Email us your feedback.
Last updated: 1/9/2012 4:28:35 PM


Creating a case

Clicking on Create Case from the Home or My Cases pages in Dovetail Mobile Agent allows the agent to create a case.

Out of the box case creation involves answering only four questions:

  • Which customer is the case concerning?
  • What is the case title?
  • What is the case severity?
  • What are the case details?

Finding a customer

  1. The first step in creating a case is to find the customer. Dovetail Mobile Agent uses search technology to make it easy to find the customer being helped.
    • Enter customer information into the Find Customer search box. You can search by name, phone number or the site which they are working.
  2. You will be presented with a list of customers matching your search criteria.
    • Click on the desired customer.
    • Refine your search if the desired customer is not found.

Enter case details

  1. Next you will be asked to enter case details such as title, severity and a case description.
    • Enter case details.
    • Click on Create

Working the case

After case creation you will be taken to the case summary page from which you will be able to work the case.

See Also

Using Dovetail Mobile Agent

Search

Working with Cases

Working with Subcases

Working with Attachments

Viewing cases or subcases in your queues

Monitoring workgroup activities

Working with solutions

Password Reset

Next

Viewing cases or subcases in your queues
Creating a case

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 2:52:04 PM


Viewing cases or subcases in your queues

The Home screen lists all of your queues that contain cases or subcases.

  1. From the Home screen, select a queue from the My Queues With Items section. If no queues appear, none of your queues currently contain any cases or subcases.
  2. Select the case or subcase to view the details of that object.

See Also

Using Dovetail Mobile Agent

Search

Working with Cases

Working with Subcases

Working with Attachments

Creating a case

Monitoring workgroup activities

Working with solutions

Password Reset

Next

Monitoring workgroup activities
Viewing cases or subcases in your queues

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 12:00:28 PM


Monitoring workgroup activities

You can view all of your workgroup's activities from Your Workgroup's Recent Activity page.

  1. From the Home screen, select Your Workgroup's Recent Activity.

    The screen lists all of your workgroup's case and subcase activities for the last day. To expand the list, select Last 3 Days or Last 7 Days.

  2. From this page, you can perform the following actions:
    • Select the case or subcase to view the details of that object.
    • Select the case owner's name to view information about the employee, including their phone number, email address, workgroup name, queue membership, and their open items.

Agent Workgroup Administration

Dovetail customers can change the workgroup an agent belongs to using Dovetail Agent or Dovetail Admin.

See Also

Using Dovetail Mobile Agent

Search

Working with Cases

Working with Subcases

Working with Attachments

Creating a case

Viewing cases or subcases in your queues

Working with solutions

Password Reset

Next

Working with solutions
Monitoring workgroup activities

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 12:01:42 PM


Working with solutions

Dovetail Mobile Agent exposes your Dovetail CRM knowledge base to your mobile customers and agents. A common scenario for an agent is to recommend that a customer apply a known solution to a problem. Dovetail Mobile Agent allows your agents to easily Send A Solution as an email logged to a case.

To Send a Solution to a Case

  1. When viewing a solution click on the Send To Case link.
  2. Select a case to receive the solution.
  3. Review the contents of the email to be sent to the case contact.
  4. Optionally you can uncheck Link Solution To Case

See Also

Using Dovetail Mobile Agent

Search

Working with Cases

Working with Subcases

Working with Attachments

Creating a case

Viewing cases or subcases in your queues

Monitoring workgroup activities

Password Reset

Next

Password Reset
Working with solutions

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 2:53:54 PM


Password Reset

Dovetail Mobile Agent allows users who have forgotten their password to reset it, in an automated process, without the need for an administrator to reset it manually.

  1. From the login page, click on the Forgot your password? link.
  2. Enter either a login name or the email address of the user.
  3. An email will be sent to the user which contains a link that will take them to a reset password page. The email will be sent to the email address on the user/employee record in the database.
  4. The user will be prompted to enter and confirm a new password.
  5. The user will then be automatically logged in.

Additional Information regarding Password Reset

  • The Rulemanager application is used to send the email to the user. Rulemanager must be running, and must be able to successfully send email for this process to function.
  • The link sent to the user includes a security token. For security reasons, the token can only be used once, and expires after 48 hours.

See Also

Using Dovetail Mobile Agent

Search

Working with Cases

Working with Subcases

Working with Attachments

Creating a case

Viewing cases or subcases in your queues

Monitoring workgroup activities

Working with solutions
Password Reset

Did this topic help you? Email us your feedback.
Last updated: 9/27/2010 4:46:45 PM


Dovetail Mobile Agent


Did this topic help you? Email us your feedback.
Last updated: 5/18/2016 2:33:50 PM


Contents Index Search